CVE-2026-14265- Deserialization of Untrusted Data in AWS Advanced JDBC Wrapper RemoteQueryCachePlugin

Advanced Jdbc ยท 2026-10-19

Actions

Rate this issue

Technical Details

Affected Versions >=3.3.0, <=4.0.0
Regions all
CVE IDs CVE-2026-14265
Migration Required Yes
Cost Impact Neutral
IaC Impact High

What This Means

For DevOps Teams

Update the AWS Advanced JDBC Wrapper to version 4.0.1 and disable the RemoteQueryCachePlugin if an immediate upgrade is not feasible, to address the deserialization vulnerability (CVE-2026-14265) and prevent potential security breaches.

For Platform Teams

Deploy the latest AWS Advanced JDBC Wrapper version 4.0.1 across all relevant environments to resolve the deserialization issue in the RemoteQueryCachePlugin, enhancing overall platform security and reliability.

For Executives

Implement the upgrade to AWS Advanced JDBC Wrapper version 4.0.1 to mitigate the risk of arbitrary code execution due to deserialization of untrusted data, ensuring application security and maintaining customer trust.

Source

View original AWS announcement โ†’

Weekly AWS Digest in Your Inbox

No spam, no headlines. Just a weekly summary of the 3โ€“7 AWS changes that matter for DevOps and Platform teams.

๐Ÿ“ง Exactly 1 email per week โ€ข Every Tuesday โ€ข Unsubscribe anytime

Today: AWS only. Coming next: Azure and other major clouds.